PHPBB3.2无法安装

phpBB 3.2.X 相关的使用、安装等话题
版面规则
《发帖时,请复制下列格式文本,提供完整的信息,勿简略发布》


###### 以下为“基本的提问格式” ######
  • 主机操作系统: Windows (XP, 7, 8, 10)、Linux(Redhat,Centos, Mandrake等等)、或者其他的(请务必注明版本)
  • 快速架站程序: AppServ、XAMPP 等等(请务必注明版本号)
  • 您的上网方式:ADSL、Cable、FTTB等等 (请务必留下 ISP 名称或 ISP 官网)
  • 您安装的程序: Apache + php + MySQL 或者其他的组合 (请务必留下版本号,如果使用上面的快速架站程序就不必写了)
  • 您的 phpBB 版本: phpBB 3.2.2
  • 您的域名: 比如 phpbbchinese.com
  • 您的 phpBB 网址: 比如 https://www.phpbbchinese.com/
###### 以上为“基本的提问格式” ######

  • 安装扩展: 请注明安装扩展的名称,版本以及参考链接(非扩展问题免填)
  • 安装风格: 请注明安装的风格名称,版本以及参考链接(非风格问题免填)
  • 错误代码: 请使用 Code 标签将错误代码标识出来,如下:

代码: 全选

错误代码
  • 错误状态:如果没有错误代码,请直接贴出截图,或者是详细叙述错误状态内容。
备注:
如果需要,请提供测试用的账号与密码
若是管理账号,请使用短信联系站长
回复
sunxmin
新注册用户
新注册用户
新手上路
新手上路
帖子: 1
注册时间: 2017年4月13日 15:51

PHPBB3.2无法安装

帖子 sunxmin » 2017年4月13日 15:54

Apache+MySQL+PHP环境都配置好了。。测试页面没问题。
从首页下载了3.2的中文版解压缩,打开后能看到首页简介。但是上方只有一个安装按钮。点击了没有反应。有人遇到过这种情况吗



头像
davidyin
网站管理员
网站管理员
Medal 3
Medal 3
帖子: 885
注册时间: 2015年11月19日 01:50
联系:

Re: PHPBB3.2无法安装

帖子 davidyin » 2017年4月14日 09:32

没看到过这种情况,给个截图看看?

请按照这个提问的要求来提供信息。
viewtopic.php?f=6&t=78

否则很难知道你遇到的是什麽问题。
居住在西八区,有时差,提问请按照“通用提问格式”提问,未必能及时回复,见谅。
提供 phpBB 服务

lhcdg
新注册用户
新注册用户
新手上路
新手上路
帖子: 1
注册时间: 2017年5月5日 09:46

Re: PHPBB3.2无法安装

帖子 lhcdg » 2017年5月5日 09:50

我也遇到了相同的情况,但我用的Linode VPS的环境是:
Nginx + MySQL + PHP

头像
davidyin
网站管理员
网站管理员
Medal 3
Medal 3
帖子: 885
注册时间: 2015年11月19日 01:50
联系:

Re: PHPBB3.2无法安装

帖子 davidyin » 2017年5月6日 07:09

lhcdg 写了:
2017年5月5日 09:50
我也遇到了相同的情况,但我用的Linode VPS的环境是:
Nginx + MySQL + PHP
这种情况,最好把安装出错的信息给出,或者把截图贴出来,这样也好给出建议和帮助。
否则,只能猜测。

目前我的猜测是,目录权限的问题。
居住在西八区,有时差,提问请按照“通用提问格式”提问,未必能及时回复,见谅。
提供 phpBB 服务

头像
605663522
新注册用户
新注册用户
Rank 1
Rank 1
帖子: 8
注册时间: 2017年11月17日 17:00

Re: PHPBB3.2无法安装

帖子 605663522 » 2017年11月17日 17:12

点 install 页面就出现 英文 拒绝访问

头像
davidyin
网站管理员
网站管理员
Medal 3
Medal 3
帖子: 885
注册时间: 2015年11月19日 01:50
联系:

Re: PHPBB3.2无法安装

帖子 davidyin » 2017年11月18日 04:12

605663522 写了:
2017年11月17日 17:12
点 install 页面就出现 英文 拒绝访问
提问请按照“通用提问格式”提问, viewtopic.php?f=6&t=78
环境不同,出现问题的原因也就不同。
居住在西八区,有时差,提问请按照“通用提问格式”提问,未必能及时回复,见谅。
提供 phpBB 服务

baoang
注册用户
注册用户
Rank 5
Rank 5
帖子: 30
注册时间: 2018年3月28日 21:22

Re: PHPBB3.2无法安装

帖子 baoang » 2018年3月28日 21:36

我在nginx下安装,同样有这类问题。看来不止nginx,连apache也有。

其实这问题,在官方也有人提过,可参考以下的贴子,但可惜的是,似乎并没有真正的解决。

https://www.phpbb.com/community/viewtop ... &t=2419796

https://www.phpbb.com/community/viewtop ... &t=2405226

但官方在某个相似问题之后,应当是认识到了问题,因而提供了所谓的phpBB官方配置的nginx模板文件
https://www.phpbb.com/community/viewtop ... #p14601561

目前,nginx和phpBB官方均为nginx的配置模板提供了指导性模板范例,nginx官方称之为pre-canned templates,除了phpBB,还包括wordpress等许多php类的程序配置。这可能和nginx本身不同与apache的特点有关,但另一方面,我也测试了下,phpBB在某些方面是比较“欠”,其它Php程序用了通用模板能安装,它却不行(也可能是我配置水平低,其实我是业余的,但照样画猫也不行)

https://github.com/phpbb/phpbb/blob/3.2 ... ample.conf

为这个模板问题,也就是涉及到在nginx下安装phpBB3,各种方法都试过了,有时偶尔能成功,但多数情况下都不行,我的配置是Linux CentOS 6.x、php-fpm 5.6(小于这个版本,phpBB3不允许安装)、mySQL5.5(基本没超过5.5)。在网上phpBB官站找到的就是上面这几个链接最相关的了,但是结果是无果,最后在中文搜索引擎里,查到链接,找到了这里来。想看看中文方面是否能够提供有效的解决方案。

目前确切的,出现过http404、显示得了页面,但页面变形(与css、js代码有关吧),以及http500这样的错误,但我相信,应当不是源于文件权限的问题,而与phpBB官方安装程序有关,特别是/app.php/这样的表达方法。

代码: 全选

    server {
        #listen 80;
        server_name www.myforums.com;

        root /path/to/phpbb;

        location / {
            # phpBB uses index.htm
            index index.php index.html index.htm;
            try_files $uri $uri/ @rewriteapp;
        }

        location @rewriteapp {
            rewrite ^(.*)$ /app.php/$1 last;
        }

        # Deny access to internal phpbb files.
        location ~ /(config\.php|common\.php|cache|files|images/avatars/upload|includes|(?<!ext/)phpbb|store|vendor) {
            deny all;
            # deny was ignored before 0.8.40 for connections over IPv6.
            # Use internal directive to prohibit access on older versions.
            internal;
        }

        # Pass the php scripts to fastcgi server specified in upstream declaration.
        location ~ \.php(/|$) {
            # Unmodified fastcgi_params from nginx distribution.
            include fastcgi_params;
            # Necessary for php.
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            fastcgi_param PATH_INFO $fastcgi_path_info;
            fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
            fastcgi_param DOCUMENT_ROOT $realpath_root;
            try_files $uri $uri/ /app.php$is_args$args;
            fastcgi_pass php;
        }

        # Correctly pass scripts for installer
        location /install/ {
            # phpBB uses index.htm
            try_files $uri $uri/ @rewrite_installapp;

            # Pass the php scripts to fastcgi server specified in upstream declaration.
            location ~ \.php(/|$) {
                # Unmodified fastcgi_params from nginx distribution.
                include fastcgi_params;
                # Necessary for php.
                fastcgi_split_path_info ^(.+\.php)(/.*)$;
                fastcgi_param PATH_INFO $fastcgi_path_info;
                fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
                fastcgi_param DOCUMENT_ROOT $realpath_root;
                try_files $uri $uri/ /install/app.php$is_args$args;
                fastcgi_pass php;
            }
        }

        location @rewrite_installapp {
            rewrite ^(.*)$ /install/app.php/$1 last;
        }

头像
davidyin
网站管理员
网站管理员
Medal 3
Medal 3
帖子: 885
注册时间: 2015年11月19日 01:50
联系:

Re: PHPBB3.2无法安装

帖子 davidyin » 2018年3月29日 06:10

你把你遇到的问题时的安装环境列一下,我来试试重现错误。

下面这个连接是建议使用的环境和配置
viewtopic.php?f=18&t=659
居住在西八区,有时差,提问请按照“通用提问格式”提问,未必能及时回复,见谅。
提供 phpBB 服务

baoang
注册用户
注册用户
Rank 5
Rank 5
帖子: 30
注册时间: 2018年3月28日 21:22

Re: PHPBB3.2无法安装

帖子 baoang » 2018年4月5日 16:21

davidyin 写了:
2018年3月29日 06:10
你把你遇到的问题时的安装环境列一下,我来试试重现错误。

下面这个连接是建议使用的环境和配置
viewtopic.php?f=18&t=659
多谢管理员!

这么多天,我过来说一下我的情况。

我在搬瓦工的机器上试了多次,到目前为止,终于可以成功了,也就是应用那个nginx官方提供的precanned模板——其实也就是phpbb官方提供的模板(两者几乎一样,nginx引用的应当是phpbb官方的某个版本)。虽然还理解不了并且也不知道如何调整(比如说,我希望将phpBB3这个目录放在根目录下,即wwwroot/phpBB3/这样时),但好歹可以(在网站根目录下)安装成功。

因为我是使用的Vesta的面板,在6.9和后来7.x的CentOS上都试了,好象第一次安装顺利是在7.x上的,其中原因不清楚,因为到处改它的模板和phpBB的那个模板,也搞不清是哪个模板是哪时改的。但后来细细回想了下,问题可能与cgi的sock匹配有关,在phpBB官方提供的nginx模板文件中,它的fastcgi是指向php的,但是在Vesta的模板中,它用了一个叫什么%lsnr%的变量,这样当用户在面板的模板中选择default时,它就变成127.0.0.1:9001的形式,而如果选择socks时,它变成了socks也就是var/run/……那个样子。也就是说,phpBB官方提供的连接方式是写死的,估计http500的主要问题跟这个有关,而再之前的404找不到页面,就是跟phpBB官方采用的不同的安装路径的设计有关了。

在nginx下用Vesta面板安装,虽然最后总算可以正常安装下去,但后期仍然会出不少问题,比如我在本机xmapp上装了phpBB,Apache的web服务器,它什么问题也没有,可以正常搜索,并且安装和使用皮肤都很正常。然而到了nginx下,就算可以建立搜索库,一去搜索框搜索操作,立刻又http500了,不知道这是否和SSL有关,因为我在调phpBB时,同时也在学安装SSL的东西。

现在,我又尝试了下另一款面板,CyberPanel,这款是基于OpenLiteSpeed的服务器的,是Apache的相当好的替代品。因为内存只有512MB,不方便安装Apache再挂两三个域名(其实只有一个站,但是有两三个子域名,而又不知道如何去写rewrite同时去满足强制https和subdomain指向subdirectory,所以只能一个子域名做成一个站这样的形式),只能选择非Apache的模式了。

回复