phpBB 升级的重要步骤

phpBB 3.2.X 相关的使用、安装等话题
版面规则
《发帖时,请复制下列格式文本,提供完整的信息,勿简略发布》


###### 以下为“基本的提问格式” ######
  • 主机操作系统: Windows (XP, 7, 8, 10)、Linux(Redhat,Centos, Mandrake等等)、或者其他的(请务必注明版本)
  • 快速架站程序: AppServ、XAMPP 等等(请务必注明版本号)
  • 您的上网方式:ADSL、Cable、FTTB等等 (请务必留下 ISP 名称或 ISP 官网)
  • 您安装的程序: Apache + php + MySQL 或者其他的组合 (请务必留下版本号,如果使用上面的快速架站程序就不必写了)
  • 您的 phpBB 版本: phpBB 3.2.2
  • 您的域名: 比如 phpbbchinese.com
  • 您的 phpBB 网址: 比如 https://www.phpbbchinese.com/
###### 以上为“基本的提问格式” ######

  • 安装扩展: 请注明安装扩展的名称,版本以及参考链接(非扩展问题免填)
  • 安装风格: 请注明安装的风格名称,版本以及参考链接(非风格问题免填)
  • 错误代码: 请使用 Code 标签将错误代码标识出来,如下:

代码: 全选

错误代码
  • 错误状态:如果没有错误代码,请直接贴出截图,或者是详细叙述错误状态内容。
备注:
如果需要,请提供测试用的账号与密码
若是管理账号,请使用短信联系站长
回复
头像
davidyin
网站管理员
网站管理员
Medal 3
Medal 3
帖子: 885
注册时间: 2015年11月19日 01:50
联系:

phpBB 升级的重要步骤

帖子 davidyin » 2017年1月19日 14:34

1) 任何升级,都先做好备份,备份包括文件系统以及数据库备份。
2)小版本升级,基本上可以直接升级,很少会有重大的兼容性问题。比如3.1.x系列中,或者在3.2.x系列里面可以直接升级。
3)大版本升级,需要在测试平台上先测试,看是否有大的兼容性问题,包括扩展,以及对于模板样式所作的修改是否有大问题。

如何在测试平台进行升级兼容性测试?
* 先按照生产环境的设置,安装一个测试平台。
* 把生产环境中的旧版本的文件系统以及数据库做备份,并恢复到测试平台。
* 确保测试平台上测试系统可以正常使用。
* 把所有的扩展都禁用。
* 在测试平台上做升级。
* 若能完成并可正常操作。
* 如果扩展有升级的,就先升级后,逐个启用扩展。


居住在西八区,有时差,提问请按照“通用提问格式”提问,未必能及时回复,见谅。
提供 phpBB 服务

回复